Back to overview
Downtime

Service Downtime

Sep 05 at 06:15pm BST
Affected services
Clockface Online - Home
Clockface Online - Clock Club
Clockface Online - Clocks

Resolved
Sep 05 at 06:29pm BST

Service has been restored.

Updated
Sep 05 at 06:25pm BST

We have identified a fix for this issue, and are currently implementing this. Please bare with us!

Created
Sep 05 at 06:15pm BST

Due to a database issue, our service is currently unavailable. We are working to restore access to our website as fast as possible.